Skocz do zawartości
  • 0

Problem ze skryptem na localhoście


McKee
 Udostępnij

Pytanie

Witam.

 

Posiadam skrypt z neta, do uploadu zdjęć na serwer, jednak mam dwa problemy. 

 

<?php 
echo '<?xml version="1.0" encoding="iso-8859-2"?>'; 
?> 
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-
transitional.dtd"> 
<html> 
<head> 
<meta http-equiv="Content-type" content="text/html; charset=iso-8859-2" /> 
<title>Upload Images</title> 
</head> 
<body> 

<div> 
<form enctype="multipart/form-data" action="index.php" method="POST"> 
<input type="hidden" name="MAX_FILE_SIZE" value="50000" /> 
<input name="plik" type="file" /> 
<input type="submit" value="Wyślij plik" /> 
</form> 
</div> 
<br>
<br>
<?php 
$plik_tmp = $_FILES['plik']['tmp_name']; 
$plik_nazwa = $_FILES['plik']['name']; 
$plik_rozmiar = $_FILES['plik']['size']; 

if(is_uploaded_file($plik_tmp)) { 
     move_uploaded_file($plik_tmp, "upload/$plik_nazwa"); 
     echo "<b>Link do pliku:</b>   $plik_nazwa <br>
     <b>Rozmiar:</b>  $plik_rozmiar bajtów został przesłany na serwer!"; 
} 
?> 
</body> 
</html>

 

1. Jak zrobić żeby po przesłaniu pliku wyświetlał się  "klikalny" link do obrazu ? Chodzi mi że na przykład jak prześlę zdjęcie to w linijce "Link do pliku" faktycznie wyświetlał mi się link do niego a nie sama nazwa pliku z rozszerzeniem ? 

2. Mam problem z tym skryptem na loklahoscie na xaampie, a mianowicie, skrypt niby działa poprawnie ale gdy chce osadzić obrazek na np: na forum nie wyświetla mi tego obrazka, pomimo że jest on dodany.  Na normalnym hostingu problemu nie ma. W czym może  tkwić problem ? na xaampie mam php 5 a na hostingu php 7 ale to chyba nie to ... 

Odnośnik do komentarza
Udostępnij na innych stronach

1 odpowiedź na to pytanie

Rekomendowane odpowiedzi

  • 0
Cytat

2. Mam problem z tym skryptem na loklahoscie na xaampie, a mianowicie, skrypt niby działa poprawnie ale gdy chce osadzić obrazek na np: na forum nie wyświetla mi tego obrazka, pomimo że jest on dodany.  Na normalnym hostingu problemu nie ma. W czym może  tkwić problem ? na xaampie mam php 5 a na hostingu php 7 ale to chyba nie to ... 

Serio? Sam sobie odpowiedziałeś. "Mam problem z tym skryptem na loCALhoscie".

Odnośnik do komentarza
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Zaloguj się poniżej.

Zaloguj się
 Udostępnij

  • Ostatnio przeglądający forum Problem ze skryptem na localhoście   0 użytkowników
    • Brak zarejestrowanych użytkowników przeglądających tę stronę.
×
×
  • Dodaj nową pozycję...