Skocz do zawartości

Problem z bannerami


Rekomendowane odpowiedzi

  • Aive zmienił(a) tytuł na Problem z bannerami
13 godzin temu, lulek123321 napisał:

Twój banner pewnie nie ma logów.

Podaj jakiś link do banneru, bądź cokolwiek abym mógł sprawdzić czy banner jest dobrze napisany...

 

Brak tła?

Źle napisane zmienne?

 

problemów może być dużo

wczesniej mi wszystko dobrze działało tło jest config dobrze ustawiony wszystko zainstalowane

 

4 godziny temu, Yaesthy napisał:

Od kiedy banner ma logi? XD :v

 

Prawidłowo skonfigurowałeś config? 

Jeżeli masz taką możliwość podeślij config (Usuń hasła i ip) oraz core, wklej to tutaj: https://pastebin.com/ i daj link.

https://pastebin.com/WLVE9f8h

Odnośnik do komentarza
Udostępnij na innych stronach

11 godzin temu, Yaesthy napisał:

Od kiedy banner ma logi? XD :v

 

Moje bannery posiadają, nie wiem jak Twoje. Dzięki temu, wiem w czym tkwi problem.

 

Przyczyn może być wiele, jak używasz starego banneru, który nie posiada żadnego dzienniku to możemy zgadywać do śmierci.

Jak nazywa się główny plik od uruchomienia banneru? Wpisz w putty php nazwa_pliku.php i pokaż nam wynik. 

 

 

Edytowane przez `.Łukasz.
Odnośnik do komentarza
Udostępnij na innych stronach

21 godzin temu, `.Łukasz. napisał:

Moje bannery posiadają, nie wiem jak Twoje. Dzięki temu, wiem w czym tkwi problem.

 

Przyczyn może być wiele, jak używasz starego banneru, który nie posiada żadnego dzienniku to możemy zgadywać do śmierci.

Jak nazywa się główny plik od uruchomienia banneru? Wpisz w putty php nazwa_pliku.php i pokaż nam wynik. 

 

 

Tak xdd

https://imgur.com/a/jQukrrs

Odnośnik do komentarza
Udostępnij na innych stronach

Dnia 19.12.2018 o 21:56, Zemeer napisał:

@`.Łukasz. Miałem już ten banner nadal jest to samo. Próbowalem też reinstalacje serwera i i również nie pomogło

http://ts3-explosion.pl/BannerTS3-master/

Przedstaw nam krok po kroku jakie czynności robisz w instalacji, konfiguracji banneru. Wtedy, będziemy wiedzieli gdzie robisz błąd i go rozwiążemy a zarazem, nauczymy Cię! 

Odnośnik do komentarza
Udostępnij na innych stronach

17 godzin temu, `.Łukasz. napisał:
apt-get install php5-gd && service apache2 restart

 

Nadal nie działa i wyskakuje coś takiego

 

Package php5-gd is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

 

E: Package 'php5-gd' has no installation candidate
 

Mam php 7.0 i teraz wyskakuje  coś takiego

PHP-GD not installed >> http://php.net/manual/en/book.image.php

 

Jak wpisuje: apt-get install php7.0-gd

to mi wyskakuje:

[email protected]:~# apt-get install php7.0-gd
Reading package lists... Done
Building dependency tree
Reading state information... Done
php7.0-gd is already the newest version (7.0.33-0+deb9u1).
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
 

Edytowane przez Zemeer
Odnośnik do komentarza
Udostępnij na innych stronach

Masz po prostu już zainstalowany php7.0 

Nie wiem jak mogę Ci już pomóc, możesz mi w prywatnej wiadomości wysłać dostęp do maszyny a gdy sam osobiście znajdę rozwiązanie błędu, to go po prostu tu umieszczę. Wydaje mi się, że robisz coś źle według moich poprzednich instrukcji. 

Odnośnik do komentarza
Udostępnij na innych stronach

17 godzin temu, Zemeer napisał:

Nadal nie działa i wyskakuje coś takiego

 

Package php5-gd is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

 

E: Package 'php5-gd' has no installation candidate
 

Mam php 7.0 i teraz wyskakuje  coś takiego

PHP-GD not installed >> http://php.net/manual/en/book.image.php

 

Jak wpisuje: apt-get install php7.0-gd

to mi wyskakuje:

[email protected]:~# apt-get install php7.0-gd
Reading package lists... Done
Building dependency tree
Reading state information... Done
php7.0-gd is already the newest version (7.0.33-0+deb9u1).
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
 

Ponieważ próbujesz instalować biblioteki php5 do php7, wyskakuje taki a nie inny error.

php7-gd juz posiadasz, dlatego nie zainstalujesz tego ponownie, a sprawdzić jakie pakiety możesz są pod komendą:

sudo apt-cache search php7-*

 

Spróbuj zainstalować na system PHP5 i wtedy dopiero dograć bibliotekę php5-gd:

sudo apt-get install -y php5.6

i sprawdź jakie php już masz komendą php -v.

Jeśli będzie pisać PHP7.0, to będziesz musiał przełączyć się na php5.6 komendami:

sudo a2dismod php7.2 && sudo a2enmod php5.6 && sudo service apache2 restart && sudo update-alternatives --set php /usr/bin/php5.6 && sudo update-alternatives --set phpize /usr/bin/phpize5.6 && sudo update-alternatives --set php-config /usr/bin/php-config5.6

 

Bez nazwy-2.png

Odnośnik do komentarza
Udostępnij na innych stronach

2 godziny temu, xOstateczny napisał:

Ponieważ próbujesz instalować biblioteki php5 do php7, wyskakuje taki a nie inny error.

php7-gd juz posiadasz, dlatego nie zainstalujesz tego ponownie, a sprawdzić jakie pakiety możesz są pod komendą:

sudo apt-cache search php7-*

 

Spróbuj zainstalować na system PHP5 i wtedy dopiero dograć bibliotekę php5-gd:

sudo apt-get install -y php5.6

i sprawdź jakie php już masz komendą php -v.

Jeśli będzie pisać PHP7.0, to będziesz musiał przełączyć się na php5.6 komendami:

 

sudo a2dismod php7.2 && sudo a2enmod php5.6 && sudo service apache2 restart && sudo update-alternatives --set php /usr/bin/php5.6 && sudo update-alternatives --set phpize /usr/bin/phpize5.6 && sudo update-alternatives --set php-config /usr/bin/php-config5.6

 

 

ERROR: Module php7.2 does not exist!

 

Odnośnik do komentarza
Udostępnij na innych stronach

15 minut temu, xOstateczny napisał:

To w takim razie nie masz php7 zainstalowanego, sprawdź jaką wersję masz

PHP 7.0.33-0+deb9u1 (cli) (built: Dec  7 2018 11:36:49) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with Zend OPcache v7.0.33-0+deb9u1, Copyright (c) 1999-2017, by Zend Technologies
 

Odnośnik do komentarza
Udostępnij na innych stronach

 

1 minutę temu, Zemeer napisał:

PHP 7.0.33-0+deb9u1 (cli) (built: Dec  7 2018 11:36:49) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with Zend OPcache v7.0.33-0+deb9u1, Copyright (c) 1999-2017, by Zend Technologies
 

 

 

 

sudo a2dismod php7.0.33-0 && sudo a2enmod php5.6 && sudo service apache2 restart && sudo update-alternatives --set php /usr/bin/php5.6 && sudo update-alternatives --set phpize /usr/bin/phpize5.6 && sudo update-alternatives --set php-config /usr/bin/php-config5.6

lub

 

sudo a2dismod php7.0.33 && sudo a2enmod php5.6 && sudo service apache2 restart && sudo update-alternatives --set php /usr/bin/php5.6 && sudo update-alternatives --set phpize /usr/bin/phpize5.6 && sudo update-alternatives --set php-config /usr/bin/php-config5.6

 

Bez nazwy-2.png

Odnośnik do komentarza
Udostępnij na innych stronach

6 minut temu, xOstateczny napisał:

 

 

 

 

sudo a2dismod php7.0.33-0 && sudo a2enmod php5.6 && sudo service apache2 restart && sudo update-alternatives --set php /usr/bin/php5.6 && sudo update-alternatives --set phpize /usr/bin/phpize5.6 && sudo update-alternatives --set php-config /usr/bin/php-config5.6

lub

 

sudo a2dismod php7.0.33 && sudo a2enmod php5.6 && sudo service apache2 restart && sudo update-alternatives --set php /usr/bin/php5.6 && sudo update-alternatives --set phpize /usr/bin/phpize5.6 && sudo update-alternatives --set php-config /usr/bin/php-config5.6

 

ERROR: Module php7.0.33 does not exist!
Nadal to samo

Moge ten kod, ale pod debiana?

Odnośnik do komentarza
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Zaloguj się poniżej.

Zaloguj się
 Udostępnij

  • Ostatnio przeglądający forum Problem z bannerami   0 użytkowników
    • Brak zarejestrowanych użytkowników przeglądających tę stronę.
×
×
  • Dodaj nową pozycję...