Skocz do zawartości

[Pytanie] błąd z pluginem Skript


Polecane posty

Wrzucam latest.log
 

Spoiler

[01:32:24] [Server thread/INFO]: Starting minecraft server version 1.15.2
[01:32:24] [Server thread/INFO]: Loading properties
[01:32:24] [Server thread/INFO]: Default game type: CREATIVE
[01:32:24] [Server thread/INFO]: Generating keypair
[01:32:24] [Server thread/INFO]: Starting Minecraft server on 10.2.168.120:44260
[01:32:24] [Server thread/INFO]: Using epoll channel type
[01:32:25] [Server thread/INFO]: This server is running CraftBukkit version git-Bukkit-8160e29 (MC: 1.15.2) (Implementing API version 1.15.2-R0.1-SNAPSHOT)
[01:32:30] [Server thread/WARN]: Plugin PermissionsEx v1.23.5 does not specify an api-version.
[01:32:30] [Server thread/WARN]: Plugin EasySetSpawn v3.3 does not specify an api-version.
[01:32:30] [Server thread/WARN]: Plugin MOTD v1.0.0 does not specify an api-version.
[01:32:30] [Server thread/WARN]: Plugin KajAutoMessage v1.0 does not specify an api-version.
[01:32:30] [Server thread/WARN]: Plugin PreciousStones v10.0.4 does not specify an api-version.
[01:32:30] [Server thread/INFO]: [WorldEdit] Loading WorldEdit v7.1.0;8e55131
[01:32:31] [Server thread/INFO]: Got request to register class com.sk89q.worldedit.bukkit.BukkitServerInterface with WorldEdit [[email protected]]
[01:32:31] [Server thread/INFO]: [Colored Signs] Loading ColoredSigns v5.0.0
[01:32:31] [Server thread/INFO]: [PermissionsEx] Loading PermissionsEx v1.23.5
[01:32:31] [Server thread/WARN]: [PermissionsEx] This server is in offline mode. Unless this server is configured to integrate with a supported proxy (see http://dft.ba/-8ous), UUIDs *may not be stable*!
[01:32:31] [Server thread/INFO]: [EasySetSpawn] Loading EasySetSpawn v3.3
[01:32:31] [Server thread/INFO]: [MOTD] Loading MOTD v1.0.0
[01:32:31] [Server thread/INFO]: [PexTabCompleter] Loading PexTabCompleter v1.3.1
[01:32:31] [Server thread/INFO]: [Vault] Loading Vault v1.7.3-b131
[01:32:31] [Server thread/INFO]: [KajAutoMessage] Loading KajAutoMessage v1.0
[01:32:31] [Server thread/INFO]: [Multiverse-Core] Loading Multiverse-Core v4.3.0-b846
[01:32:31] [Server thread/INFO]: [Essentials] Loading Essentials v2.19.0-dev+221-1556b91
[01:32:31] [Server thread/INFO]: [EssentialsChat] Loading EssentialsChat v2.18.0.0
[01:32:31] [Server thread/INFO]: [PreciousStones] Loading PreciousStones v10.0.4
[01:32:31] [Server thread/INFO]: [Skript] Loading Skript v2.6-beta2
[01:32:31] [Server thread/INFO]: [WorldEdit] Enabling WorldEdit v7.1.0;8e55131
[01:32:32] [Server thread/WARN]: SLF4J: No SLF4J providers were found.
[01:32:32] [Server thread/WARN]: SLF4J: Defaulting to no-operation (NOP) logger implementation
[01:32:32] [Server thread/WARN]: SLF4J: See http://www.slf4j.org/codes.html#noProviders for further details.
[01:32:37] [Server thread/INFO]: WEPIF: Using the Bukkit Permissions API.
[01:32:37] [Server thread/INFO]: Using com.sk89q.worldedit.bukkit.adapter.impl.Spigot_v1_15_R2 as the Bukkit adapter
[01:32:38] [Server thread/WARN]: [WorldEdit] ====================================================
[01:32:38] [Server thread/WARN]: [WorldEdit]  WorldEdit works better if you use Paper 
[01:32:38] [Server thread/WARN]: [WorldEdit]  as your server software. 
[01:32:38] [Server thread/WARN]: [WorldEdit]   
[01:32:38] [Server thread/WARN]: [WorldEdit]  Paper offers significant performance improvements,
[01:32:38] [Server thread/WARN]: [WorldEdit]  bug fixes, security enhancements and optional
[01:32:38] [Server thread/WARN]: [WorldEdit]  features for server owners to enhance their server.
[01:32:38] [Server thread/WARN]: [WorldEdit]   
[01:32:38] [Server thread/WARN]: [WorldEdit]  Paper includes Timings v2, which is significantly
[01:32:38] [Server thread/WARN]: [WorldEdit]  better at diagnosing lag problems over v1.
[01:32:38] [Server thread/WARN]: [WorldEdit]   
[01:32:38] [Server thread/WARN]: [WorldEdit]  All of your plugins should still work, and the
[01:32:38] [Server thread/WARN]: [WorldEdit]  Paper community will gladly help you fix any issues.
[01:32:38] [Server thread/WARN]: [WorldEdit]   
[01:32:38] [Server thread/WARN]: [WorldEdit]  Join the Paper Community @ https://papermc.io
[01:32:38] [Server thread/WARN]: [WorldEdit] ====================================================
[01:32:38] [Server thread/INFO]: [Vault] Enabling Vault v1.7.3-b131
[01:32:38] [Server thread/INFO]: [Vault] [Economy] Essentials Economy found: Waiting
[01:32:38] [Server thread/INFO]: [Vault] [Permission] PermissionsEx found: Waiting
[01:32:38] [Server thread/INFO]: [Vault] [Permission] SuperPermissions loaded as backup permission system.
[01:32:38] [Server thread/INFO]: [Vault] [Chat] PermissionsEx found: Waiting
[01:32:38] [Server thread/INFO]: [Vault] Enabled Version 1.7.3-b131
[01:32:38] [Server thread/INFO]: WEPIF: Using the Bukkit Permissions API.
[01:32:38] [Server thread/WARN]: **** SERVER IS RUNNING IN OFFLINE/INSECURE MODE!
[01:32:38] [Server thread/WARN]: The server will make no attempt to authenticate usernames. Beware.
[01:32:38] [Server thread/WARN]: While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
[01:32:38] [Server thread/WARN]: To change this, set "online-mode" to "true" in the server.properties file.
[01:32:38] [Server thread/INFO]: Preparing level "world"
[01:32:38] [Server thread/INFO]: Reloading ResourceManager: Default, bukkit
[01:32:38] [Server thread/INFO]: Loaded 6 recipes
[01:32:39] [Server thread/INFO]: Registering commands with com.sk89q.worldedit.bukkit.BukkitServerInterface
[01:32:39] [Server thread/INFO]: Preparing start region for dimension 'world'/minecraft:overworld
[01:32:40] [Server thread/INFO]: Preparing spawn area: 0%
[01:32:40] [Server thread/INFO]: Preparing spawn area: 0%
[01:32:40] [Server thread/INFO]: Preparing spawn area: 15%
[01:32:40] [Server thread/INFO]: Time elapsed: 1254 ms
[01:32:40] [Server thread/INFO]: Preparing start region for dimension 'world_nether'/minecraft:the_nether
[01:32:41] [Server thread/INFO]: Preparing spawn area: 0%
[01:32:41] [Server thread/INFO]: Preparing spawn area: 0%
[01:32:41] [Server-Worker-4/INFO]: Preparing spawn area: 83%
[01:32:42] [Server-Worker-4/INFO]: Preparing spawn area: 83%
[01:32:42] [Server-Worker-1/INFO]: Preparing spawn area: 84%
[01:32:43] [Server-Worker-6/INFO]: Preparing spawn area: 91%
[01:32:43] [Server thread/INFO]: Time elapsed: 2791 ms
[01:32:43] [Server thread/INFO]: Preparing start region for dimension 'world_the_end'/minecraft:the_end
[01:32:43] [Server thread/INFO]: Preparing spawn area: 0%
[01:32:43] [Server-Worker-1/INFO]: Preparing spawn area: 83%
[01:32:44] [Server thread/INFO]: Time elapsed: 867 ms
[01:32:44] [Server thread/INFO]: [Colored Signs] Enabling ColoredSigns v5.0.0
[01:32:44] [Server thread/INFO]: [PermissionsEx] Enabling PermissionsEx v1.23.5
[01:32:44] [Server thread/INFO]: [PermissionsEx] Initializing file backend
[01:32:44] [Server thread/INFO]: [PermissionsEx] Permissions file successfully reloaded
[01:32:44] [Server thread/INFO]: WEPIF: PermissionsEx detected! Using PermissionsEx for permissions.
[01:32:44] [Server thread/INFO]: [Vault][Permission] PermissionsEx hooked.
[01:32:44] [Server thread/INFO]: [Vault] [Vault][Chat] PermissionsEx_Chat hooked.
[01:32:44] [Server thread/INFO]: [EasySetSpawn] Enabling EasySetSpawn v3.3
[01:32:44] [Server thread/INFO]: [EasySetSpawn] Enabled!
[01:32:44] [Server thread/INFO]: [MOTD] Enabling MOTD v1.0.0
[01:32:44] [Server thread/INFO]: [PexTabCompleter] Enabling PexTabCompleter v1.3.1
[01:32:44] [Server thread/INFO]: [KajAutoMessage] Enabling KajAutoMessage v1.0
[01:32:44] [Server thread/INFO]: [Multiverse-Core] Enabling Multiverse-Core v4.3.0-b846
[01:32:44] [Server thread/WARN]: [Multiverse-Core] "Multiverse-Core v4.3.0-b846" has registered a listener for org.bukkit.event.entity.EntityCreatePortalEvent on method "public void com.onarandombox.MultiverseCore.listeners.MVPortalListener.entityPortalCreate(org.bukkit.event.entity.EntityCreatePortalEvent)", but the event is Deprecated. "Server performance will be affected"; please notify the authors [dumptruckman, Rigby, fernferret, lithium3141, main--].
[01:32:44] [Server thread/INFO]: [Multiverse-Core] §aWe are aware of the warning about the deprecated event. There is no alternative that allows us to do what we need to do and performance impact is negligible. It is safe to ignore.
[01:32:44] [Server thread/INFO]: Preparing start region for dimension 'hub'/minecraft:overworld
[01:32:45] [Server thread/INFO]: Preparing spawn area: 0%
[01:32:45] [Thread-14/WARN]: [PermissionsEx] The updater could not find any files for the project id 31279
[01:32:45] [Server thread/INFO]: Preparing spawn area: 0%
[01:32:47] [Server-Worker-7/INFO]: Preparing spawn area: 83%
[01:32:47] [Server-Worker-5/INFO]: Preparing spawn area: 83%
[01:32:47] [Server-Worker-4/INFO]: Preparing spawn area: 83%
[01:32:47] [Server thread/INFO]: Preparing spawn area: 83%
[01:32:47] [Server-Worker-3/INFO]: Preparing spawn area: 92%
[01:32:48] [Server-Worker-4/INFO]: Preparing spawn area: 94%
[01:32:48] [Server thread/INFO]: Time elapsed: 3727 ms
[01:32:48] [Server thread/INFO]: Preparing start region for dimension 'mapka'/minecraft:overworld
[01:32:48] [Server thread/INFO]: Preparing spawn area: 0%
[01:32:48] [Server thread/INFO]: Preparing spawn area: 0%
[01:32:49] [Server thread/INFO]: Preparing spawn area: 83%
[01:32:49] [Server thread/INFO]: Time elapsed: 1135 ms
[01:32:49] [Server thread/INFO]: [Multiverse-Core] 5 - World(s) loaded.
[01:32:49] [Server thread/WARN]: Warning: Nashorn engine is planned to be removed from a future JDK release
[01:32:49] [Server thread/INFO]: [Multiverse-Core] Version 4.3.0-b846 (API v24) Enabled - By dumptruckman, Rigby, fernferret, lithium3141 and main--
[01:32:49] [Server thread/INFO]: [Essentials] Enabling Essentials v2.19.0-dev+221-1556b91
[01:32:49] [Server thread/INFO]: [Essentials] You are running a server with limited API functionality. EssentialsX will still work, but certain features may be disabled.
[01:32:49] [Server thread/WARN]: [Essentials] §4Version mismatch! Please update EssentialsChat to the same version.
[01:32:50] [Server thread/INFO]: Attempting to convert old kits in config.yml to new kits.yml
[01:32:50] [Server thread/INFO]: No kits found to migrate.
[01:32:50] [Server thread/INFO]: Loaded 36837 items from items.json.
[01:32:50] [Server thread/INFO]: Using locale en_US
[01:32:50] [Server thread/INFO]: [Essentials] ServerListPingEvent: Spigot iterator API
[01:32:50] [Server thread/INFO]: [Essentials] Starting Metrics. Opt-out using the global bStats config.
[01:32:50] [Server thread/INFO]: [Vault] [Economy] Essentials Economy hooked.
[01:32:50] [Server thread/INFO]: [Essentials] Using Vault based permissions (PermissionsEx)
[01:32:50] [Server thread/INFO]: [EssentialsChat] Enabling EssentialsChat v2.18.0.0
[01:32:50] [Server thread/WARN]: [EssentialsChat] §4Version mismatch! Please update all Essentials jars to the same version.
[01:32:50] [Server thread/INFO]: [EssentialsChat] Starting Metrics. Opt-out using the global bStats config.
[01:32:50] [Server thread/INFO]: [PreciousStones] Enabling PreciousStones v10.0.4
[01:32:50] [Server thread/INFO]: [PreciousStones] Version 10.0.4 loaded
[01:32:50] [Server thread/INFO]: [PreciousStones] SQLite Connection successful
[01:32:50] [Server thread/INFO]: [Skript] Enabling Skript v2.6-beta2
[01:32:50] [Server thread/ERROR]: Error occurred while enabling Skript v2.6-beta2 (Is it up to date?)
java.lang.NoClassDefFoundError: net/md_5/bungee/api/ChatColor
    at ch.njol.skript.util.Utils.<clinit>(Utils.java:478) ~[?:?]
    at ch.njol.skript.util.Version.<init>(Version.java:64) ~[?:?]
    at ch.njol.skript.Skript.onEnable(Skript.java:331) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:263) ~[server.jar:git-Bukkit-8160e29]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:344) [server.jar:git-Bukkit-8160e29]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:416) [server.jar:git-Bukkit-8160e29]
    at org.bukkit.craftbukkit.v1_15_R1.CraftServer.enablePlugin(CraftServer.java:448) [server.jar:git-Bukkit-8160e29]
    at org.bukkit.craftbukkit.v1_15_R1.CraftServer.enablePlugins(CraftServer.java:374) [server.jar:git-Bukkit-8160e29]
    at net.minecraft.server.v1_15_R1.MinecraftServer.a(MinecraftServer.java:448) [server.jar:git-Bukkit-8160e29]
    at net.minecraft.server.v1_15_R1.DedicatedServer.init(DedicatedServer.java:254) [server.jar:git-Bukkit-8160e29]
    at net.minecraft.server.v1_15_R1.MinecraftServer.run(MinecraftServer.java:762) [server.jar:git-Bukkit-8160e29]
    at java.lang.Thread.run(Thread.java:834) [?:?]
Caused by: java.lang.ClassNotFoundException: net.md_5.bungee.api.ChatColor
    at java.net.URLClassLoader.findClass(URLClassLoader.java:471) ~[?:?]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:146) ~[server.jar:git-Bukkit-8160e29]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:92) ~[server.jar:git-Bukkit-8160e29]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:588) ~[?:?]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:521) ~[?:?]
    ... 12 more
[01:32:50] [Server thread/INFO]: Server permissions file permissions.yml is empty, ignoring it
[01:32:51] [Server thread/INFO]: Done (13.206s)! For help, type "help"
[01:32:51] [Server thread/INFO]: Starting GS4 status listener
[01:32:51] [Server thread/INFO]: Starting remote control listener
[01:32:51] [Query Listener #1/INFO]: Query running on 10.2.168.120:25565
[01:32:51] [RCON Listener #2/INFO]: RCON running on 10.2.168.120:25575
[01:32:51] [Server thread/INFO]: [Essentials] Essentials found a compatible payment resolution method: Vault Compatibility Layer (v1.7.3-b131)!
[01:32:51] [Craft Scheduler Thread - 6/INFO]: [Vault] Checking for Updates ... 
[01:32:51] [Craft Scheduler Thread - 1/INFO]: [Essentials] §6Fetching version information...
[01:32:51] [Craft Scheduler Thread - 4/WARN]: [PreciousStones] Plugin PreciousStones v10.0.4 generated an exception while executing task 17
java.lang.NoSuchMethodError: org.bukkit.Server.getOnlinePlayers()[Lorg/bukkit/entity/Player;
    at ps.org.mcstats.Metrics.postPlugin(Metrics.java:363) ~[?:?]
    at ps.org.mcstats.Metrics.access$500(Metrics.java:68) ~[?:?]
    at ps.org.mcstats.Metrics$1.run(Metrics.java:255) ~[?:?]
    at org.bukkit.craftbukkit.v1_15_R1.scheduler.CraftTask.run(CraftTask.java:77) ~[server.jar:git-Bukkit-8160e29]
    at org.bukkit.craftbukkit.v1_15_R1.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:54) [server.jar:git-Bukkit-8160e29]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) [?:?]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) [?:?]
    at java.lang.Thread.run(Thread.java:834) [?:?]
[01:32:51] [Craft Scheduler Thread - 6/INFO]: [Vault] No new version available
[01:32:51] [Server thread/INFO]: [email protected][id=<null>,name=S1zzzU,properties={},legacy=false] (/185.227.191.55:14377) lost connection: Disconnectedlatest.log

 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Usuń easysetspawn, jego funkcje są w essentials
Koniecznie zamień permissionsex (wywal pextabcompleter) na luckperms
Zaktualizuj motd

 

Skript ci nie działa pewnie dlatego że korzystasz z przestarzałego i niebezpiecznego silnika craftbukkit, po prostu śmiech...
Użyj silnika Purpur

 

Cytat

[01:32:50] [Server thread/WARN]: [EssentialsChat] §4Version mismatch! Please update all Essentials jars to the same version.

Zaktualizuj essentials i jego rozszerzenia (link)

 Chcesz coś?
 Pisz pv lub na Discordzie!

Pomagam z Minecraftem
oraz Discordem
 JEŚLI POMOGŁEM KLIKNIJ SERDUSZKO OBOK MOJEGO POSTU ❤️

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Bądź aktywny! Zaloguj się lub utwórz konto

Tylko zarejestrowani użytkownicy mogą komentować zawartość tej strony

Utwórz konto

Zarejestruj nowe konto, to proste!

Zarejestruj nowe konto

Zaloguj się

Posiadasz własne konto? Użyj go!

Zaloguj się
  • Kto przegląda   0 użytkowników

    Brak zalogowanych użytkowników przeglądających tę stronę.

×
Okienko zamknie się za 5 sekund...