Skocz do zawartości

[PROBLEM] ntoskrnl BSOD "Unexpected Store Exception"


Polecane posty

Cześć wszystkim!

Od kilku dni mam problem z BSODem. Do tej pory wystąpił dwa razy.

Początkowo komputer zaczął się strasznie mulić, eksplorator windows potrafił się zaciąć i resetować kilka razy zanim dało się cokolwiek zrobić.

Prawdopodobnie problem nie jest powiązany z BSODem, bo wszystko wróciło do normy po tym jak przeniosłem część plików z C na inny dysk, pomyślałem jednak że warto tutaj o tym wspomnieć.

Komunikat przy BSOdzie brzmi "Unexpected Store Exception", używając programu BlueScreenView dowiedziałem się że BSOD został spowodowany przez proces o nazwie "ntoskrnl".

Zrzut ekranu z programu:

https://ibb.co/mc6GKWd

 

Moja specyfikacja:

CPU: Ryzen 5 5600x
GPU: GTX 1080ti
MOBO: MSI MAG B550M MORTAR
PSU: SilentiumPC Supremo FM2 750W 80 Plus Gold

 

Co może powodować ten problem?

 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Nie da się jednoznacznie odpowiedzieć co powoduje, że ntoskrnl się wysypuje. Błąd 0x154 odwołuje się bardzo często do uszkodzonych plików systemowych, czasami do problemów z pamięcią RAM, z kolei błąd 0xef odnosi się do sterowników lub usług systemowych, lub nowo dodanych urządzeń. W takich przypadkach pomocny może okazać się systemowy dziennik zdarzeń, który czasami wskazuje co powoduje, że ntoskrnl się wysypuje. Polecam zacząć od tego:

  1. Aktualizacja sterowników, w szczególności chipsetu.
  2. Sprawdź system za pomocą System File Checker'a (sfc /scannow w powershellu/cmd uruchomionym jako admin), jeśli SFC nie jest w stanie naprawić uszkodzonych plików to trzeba przelecieć system DISM (DISM /Online /Cleanup-Image /RestoreHealth), a następnie powtórzyć skanowanie SFC.
  3. Sprawdź dysk pod kątem problemów/bad sectorów (chkdsk powinien wystarczyć).
  4. Czyszczenie dysku ze zbędnych plików (za pomocą wbudowanego w system cleanera lub BleachBit jeśli wiesz co robisz, CCleaner omijać szerokim łukiem).

Jeśli problem by się powtarzał możesz zaktualizować BIOS do wersji 7C94v18, która zawiera AGESA 1.2.0.3b, która nie tylko rozszerza wsparcie dla procesorów Ryzen 5000 (stepping B2), ale naprawia różne problemy związane z USB. Ewentualnie aktualizacja do Patch C (AGESA 1.2.0.3c) jeśli by się ukazała stabilna wersja BIOS.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Dziękuję za odpowiedź! Jutro spróbuję zreinstalować cały system, w międzyczasie wystąpił nowy BSOD, źródło problemu zostało określone jako WDfilter.sys.

W załączniku daję screena. 

 

 

EDIT

sfc znalazł i naprawił błędne pliki, zainstalowałem najnowsze sterowniki, zobaczymy jak to będzie działać. 

BSOD najnowsze.png

Edytowano przez Sokol1122

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Gdy SFC znajduje jakieś uszkodzone pliki to warto jeszcze raz puścić skanowanie, nie zawsze wszystkie pliki zostają naprawione.

Każdy BSOD wynika z czegoś innego - czyściłeś system lub rejestr jakimś programem? Może używałeś jakichś narzędzi, które mają zapewniać "prywatność", lub korzystałeś z jakichś porad, które miały przyśpieszyć lub zoptymalizować system? Rzadko takie problemy dzieją się same z siebie.

 

Polecam zaktualizować system do najnowszej wersji, bo ta na której siedzisz (2004/20H1) traci wsparcie w grudniu. Nie wiem dlaczego system się nie zaktualizował, być może zablokowałeś sobie aktualizacje (z czego właśnie mogą wynikać problemy z systemem). Jeśli Windows Update nie znajduje Ci żadnych aktualizacji to wtedy pomocna może okazać się strona Microsoftu.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Ano, jakiś czas temu używałem narzędzia do "oczyszczania" windowsa ze zbędnych aplikacji. Po skanowaniu przez dwa dni komputer chodził bez zarzutu, teraz wyleciał bsod:

Chyba nie będę bawił się w półśrodki i strzelę całkowitego formata. 

Dodatkowo, pokazuje mi że moja wersja systemu jest aktualna xD.

image.png

Edytowano przez Sokol1122

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Czysta instalacja systemu zdecydowanie będzie lepszym wyjściem - błędy są różne co oznacza, że dotarcie do problemu zajęłoby trochę czasu.

Według screenshotów posiadasz kompilację 19041 czyli wersję 2004/20H1, być może program źle podaje informacje. Aktualną specyfikację systemu znajdziesz w ustawieniach -> system -> informacje.

 

Pamiętasz nazwę programu, z którego korzystałeś?

 

Polecam wyposażyć się w Macrium Reflect i zacząć tworzyć okresowe backupy systemu, jeśli posiadasz dysk, na którym takie backupy możesz trzymać. Program nie jest skomplikowany, posiada bogatą dokumentację, a darmowa wersja bez problemu wystarczy do domowych zastosowań. Program jest w stanie tworzyć automatyczne backupy, dodatkowo oprócz pełnego backupu może robić obrazy różnicowe i przyrostowe co pozwala użytkownikowi stworzyć jeden pełny backup co miesiąc, a następnie różnicowe lub przyrostowe co tydzień. Przywracanie systemu z backupu jest stosunkowo proste i szybkie.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Okazało się że problem leżał nieco głębiej, windows nie był w stanie przeprowadzić formatu, ani stworzyć partycji. Pomogło jedynie wyzerowanie dysku pod linuxem, przy okazji przetestowałem dysk, wygląda na sprawny. Nowy windows zainstalowany i można się bawić. Dziękuję za pomoc!

 

EDIT

Tamten program to chyba Windows10Debloater

 

EDIT2

podczas instalowania aktualizacji znowu poleciał bsod:

teraz to już kompletnie zgłupiałem.

image.png

Edytowano przez Sokol1122

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Windows10Debloater nie jest programem do czyszczenia systemu, tylko zestawem skryptów, które jeśli użytkownik nie wie co robi mogą doprowadzić do uszkodzenia systemu lub wyłączenia funkcji, które użytkownik chce jednak pozostawić włączone (np. nagły brak synchronizacji w MS Edge). Nie polecam korzystać z tego typu zestawu skryptów jeśli autor dostatecznie nie wyjaśnia co one robią, a sam użytkownik nie wie jakie zmiany powodują w systemie. Często właśnie takie skrypty powodują, że w pewnym momencie system nadaje się wyłącznie do przeinstalowania, bo poblokował połowę krytycznych usług lub funkcji. Chcesz prywatności? Nie korzystaj z usług oraz produktów Microsoftu, Facebooka czy Google.

 

Rozumiem, że po czystej instalacji systemu nie korzystałeś już z Debloatera. Kroki, które możesz wykonać:

  • Wyłączenie opcji Fast Boot w UEFI i sprawdzenie czy BSOD'yi się pojawiają
  • Zresetowanie ustawień UEFI
  • Aktualizacja BIOS/UEFI do wersji 7C94v18
  • Sprawdzić dysk na którym instalujesz system za pomocą GSmartControl (dwu-klik na dysk -> zakładka Self-Tests -> Wybierasz typ testu Extended Self-Test i klikasz Execute).
  • Sprawdzenie RAM (z włączonym profilem XMP) za pomocą MemTest86. Trochę to potrwa, ale pozwoli z dużym prawdopodobieństwem wykluczyć problem z pamięcią operacyjną. Tutaj polecam zrobić 2 razy test.

Tworzyłeś nowe ISO/Bootowalny pendrive za pomocą Media Creation Tool/Rufus, czy wykorzystywałeś jakieś stare ISO?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Nie używałem nic takiego po formacie. Zainstalowałem system używając Media Creation Tool i pendrive. Teraz odpiąłem wszystkie dyski odprócz systemowego i skanuje go już chyba trzecim programem, póki co nic nie wykryło, CrystalDiskInfo pokazuje jego stan na 91% Dobry. Teraz trwa Long generic w Seatools. jak proces się skończy, spróbuję zastosować metody które mi poleciłeś. 

 

 

UPDATE

test dysku przeszedł bez problemów. Bios mam aktualny, teraz odpalę memtest86, jeśli nic nie wykaże, zacznę testować pozostałe dyski.

 

UPDATE2

Dyski testowały się całą noc, wszystko sprawne... 

 

UPDATE3 

Jak wrócę z zajęć to spróbuję jeszcze pomajstrować przy fast boot i UEFI, ale wątpię czy coś się zmieni. 

Edytowano przez Sokol1122

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Skoro wszystkie dyski są sprawne, a problemy z BSOD'ami na czystym systemie nadal występują to podejrzewam, że problemem jest stabilność platformy. Chciałbym wiedzieć jaki RAM dokładnie posiadasz. Dodatkowo zalecam zresetować UEFI, upewnić się, że CSM jest wyłączony w UEFI i sprawdzić czy przy wyłączonym profilu XMP BSOD'y również się pojawiają.

 

Warto przetestować stabilność za pomocą OCCT - dwa Memory Test z instrukcjami SSE oraz AVX2 z włączonym profilem XMP. Oprócz OCCT do stabilności pamięci można użyć TM5 z profilem [email protected]

 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Właśnie zresetowałem bios poprzez wyjęcie baterii, CSM jest wyłaczone. Mój ram to https://www.x-kom.pl/p/531223-pamiec-ram-ddr4-goodram-16gb-2x8gb-3600mhz-cl17-irdm-pro.html , do tej pory nie miał żadnych problemów z pracą pod XMP. Teraz XMP wyłączyłem, puszczę OCCT i TM5.

 

Edytowano przez Sokol1122

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Stabilność pamięci operacyjnej trzeba testować z włączonym XMP - jeśli wysypie błąd, wtedy można testować bez XMP. Jeśli błędów nie będzie to oznacza, że pamięć nie jest stabilna i trzeba ją ustabilizować. Żeby była jasność - nie uważam, że Twój RAM nagle się popsuł (szczególnie jeśli MemTest86 przeszedł bez problemów), bardziej skłaniam się ku temu, że IMC procesora zaczyna wysiadać, ponieważ miewałem takie przypadki - komputer tydzień chodzi bez problemów, a nagle zaczynają się losowe BSOD'y, żeby na końcu sypać BSOD'ami nawet podczas uruchamiania systemu. Losowe BSOD'y na Ryzenach 5000 były spotykane, zdychające Ryzeny po jakimś czasie również. Oczywiście nie oznacza to, że problem leży w procesorze, ponieważ problem mogą generować urządzenia podłączone do komputera. Oprócz tego zrobiłbym najprostszą rzecz - wyjął RAM i ponownie zamontował, czasem tak głupia z pozoru rzecz potrafi rozwiązać problem.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Bez XMP przeszło bez problemu, w sumie od ostatniego formatu dysku (zrobiłem jeszcze jednego dla pewności) jest spokój z bsodami, dzisiaj puszczę testy na włączonym XMP. I potyram trochę komputer w grach. Dodam że podczas testu ostatniego dysku, który trwał całą noc, komputer bsoda też nie wyłapał. Może wina leżała w uszkodzonym systemie?

 

EDIT

Chyba dalej jest coś nie tak, sfc już znajduje uszkodzone pliki, a w dzienniku zdarzeń są błędy krytyczne, bsod to chyba kwestia czasu ;_;.

Edytowano przez Sokol1122

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Możesz zrobić screenshota któregoś błędu krytycznego z dziennika zdarzeń? Kolejne pytanie to w jaki sposób stawiałeś system na nowo?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Cały czas występuje ten sam schemat błędów. System instalowałem za pomocą pendrive z programem microsoftu.

image.png

image.png

image.png

image.png

image.png

image.png

 

Edytowano przez Sokol1122

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Gdy to zrobisz wyłącz w systemie (w opcjach zasilania) Szybkie Uruchamianie. Jakie urządzenia dodatkowe masz podłączone do komputera (zewnętrzne i wewnętrzne)?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Zaczynam In-Place Upgrade, właśnie wyłączyłem szybkie uruchamianie, jedyne urządzenia podpięte do kompa, to mysz, klawiatura i monitor, w środku dodatkowo gtx 1080ti. A no i słuchawki. Wątpię by te rzeczy powodowały takie problemy.

Edit

Po In-Place upgrade z systemu nie da się korzystać, eksplorator Windows cały czas się zawiesza i restartuje, nie mogę nawet sprawdzić aktualizacji. 

EDIT2

Błędy wywalił te same

IMG_20211109_211840.jpg

Edytowano przez Sokol1122

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Bardzo dziwny przypadek, że po "zastąpieniu" systemu kompletnie nowym z ISO było gorzej niż przed.

Chciałbym zobaczyć SMART dysku systemowego z GSmartControl lub CrystalDiskInfo, jeśli posiadasz inne SSD to ich SMART także chciałbym zobaczyć.

Uruchom system w trybie awaryjnym z dostępem do sieci, następnie uruchom Powershell jako administrator, wklej komendę DISM /Online /Cleanup-Image /RestoreHealth, następnie SFC /scannow.

 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Tak to wygląda w Crystaldiskinfo, chyba już nie mam cierpliwości na to, w piątek oddam komputer do serwisu w celu postawienia diagnozy.image.png

 

EDIT

Pozostałe dyski są teraz odpięte.

Edytowano przez Sokol1122

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Dysk wygląda ok, jeśli MemTest86 również nie wykazał błędów to bez diagnostyki serwisowej się nie obędzie. Problem z Twoimi BSOD'ami jest taki, że Bug Code 0xEF często informuje nie tyle o uszkodzonym systemie co o problemach z pamięcią RAM lub dyskiem, o wiele rzadziej z zasilaczem lub płytą główną. Generalnie błędy wskazują na problemy z dyskiem lub RAM'em, jeśli problem byłby po stronie oprogramowania to czysta instalacja rozwiązałaby te problemy.

 

Poinformuj serwis o kodach błędów, które wystąpiły - 0xEF, 0x154, 0x134, 0x74, pozwoli to szybciej zdiagnozować usterkę.

Jeśli jeszcze sam byś chciał pewne rzeczy zdiagnozować to zacząłbym w tym momencie od podstaw - sprawdzenie wtyczek zasilających w komputerze (EPS, ATX, PCI-E oraz SATA), a także wyjęcie modułów RAM i próba sprawdzenia czy system się sypie na jednym module.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 2 tygodni później...

Update, niestety serwis nic nie znalazł. Przez cały tydzień komputer pracował normalnie i nie wywalił żadnego bsoda... . Mam nową teorię, w problem pojawił się gdy przeniosłem komputer do akademika, teraz zwróciłem uwagę na fakt, że gdy lodówka w pokoju zaczyna brzęczeć lub robi takie głośne "pyk", to mój monitor na kilka sekund traci obraz, zupełnie tak jakby przez chwilę brakowało mu prądu. Może to ta lodówka plus marnej jakości sieć zasilająca w akademiku powodują że komputer na chwilę traci zasilanie i zaczynają się problemy z działaniem. Myślę że w takim przypadku UPS mógłby rozwiązać ten problem. 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Bądź aktywny! Zaloguj się lub utwórz konto

Tylko zarejestrowani użytkownicy mogą komentować zawartość tej strony

Utwórz konto

Zarejestruj nowe konto, to proste!

Zarejestruj nowe konto

Zaloguj się

Posiadasz własne konto? Użyj go!

Zaloguj się
  • Kto przegląda   0 użytkowników

    Brak zalogowanych użytkowników przeglądających tę stronę.

×
Okienko zamknie się za 5 sekund...