Skocz do zawartości

Serwer na Linux Mint, problem z portami i statycznym adresem


Polecane posty

Witam!

   Nie ukrywam, że chciałem uniknąć zawracania głów szacownych forumowiczów, poniekąd dlatego, że szkolę się w technikum informatycznym i "nie wypada" mi mieć takich problemów.

Otóż, "jako klasa" byliśmy zmęczeni wynajmowaniem hostingów, postanowiliśmy więc korzystając z potencjału sieci światłowodowej postawić własny serwer.  Ochoczo wziąłem się do pracy, przynajmniej na początku.

   Początkowe próby postawienia całości na Ubuntu Serwer spełzły na niczym gdy natrafiłem na błąd którego nie byłem w stanie przeskoczyć. W ramach treningu systemem został Mint, będący lżejszy w warstwie graficznej od Ubuntu co z racji braku dedykowanej karty graficznej wydawało mi się przydatną cechą.

   Jak na załączonych obrazkach widać serwer w wersji 1.14.4 działa:

Po LAN widać.PNG   Konsola.PNG

 

   Gwoli wyjaśnień, serwer (TiNA) ze względu na brak długiego kabla znajduje się dość daleko, zmuszony więc jestem łączyć się z nim poprzez PuTTy. okazjonalnie mogę pracować nad nim bezpośrednio ale wymaga to przybrania niewygodnej pozycji, ograniczam się więc raczej do kontroli zdalnej. Mogę również połączyć się poprzez VNC, lecz ten sposób ma około 30s opóźnienia co niezwykle utrudnia, w razie potrzeby mogę jednak pozyskać tak "ss".

 

   Pierwsza komenda zwraca zewn. IP, druga (na wszelki wypadek - odpowiednik windowsowego ipconfig). Interesuje nas opcja "enp4s0:" ponieważ płyta ma uszkodzoną wbudowaną kartę sieciową i korzystam z innej połączonej przez PCIe x16. (Mam nadzieję że nie powoduje to problemów, ale głowy nie dam).

ifconfig.PNG    Edycja.PNG

 

   Oto zawartość server.properties, 192.168.0.4 to adres TiNA. Serwer nie wywala w trakcie ładowania tylko, w przypadku wpisania tego,0.0.0.0 lub pozostawienia pustego. Przez internet nie działa jednak na żadnym z nich:

własności.PNG

 

Zapora jest wyłączona, nie ustawiłem jednak na serwerze statycznego IP. Kwestię tą rozwinę dalej.

   Co do ustawień routera i zabawy z portami, próbowałem z poradnikami wykonać tę czynność na trzech routerach. Poniższe screeny przedstawiają stan obecny routera IDU-ODU 200 z nalepki dowiedziałem się, że jest to pomiot Interphone. Taki czarny z niebieskimi ledami po prawej stronie.

RT Statyczne IP.PNG  Statyczne IP ustawiłem tylko na routerze.

 

RT PF.PNG To jest zakładka oznaczona mianem Port Forwarding.

 

RT VS.PNG

 

Tyle mojej ingerencji w router. Żywię nadzieję, że popełniłem jakiś głupi błąd początkującego.

Co do statycznego IP na komputerze to nie wiem czy mam to zrobić czy nie, nie jestem też pewny jak to zrobić, konkretnie jaką dać maskę i jaką bramę.

Z góry dziękuję za pomoc.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Zapomniałem napisać, że filtrowanie portów z poziomu routera jest wyłączone, właściwie każda opcja filtracji przedstawiona w ustawieniach routera jest wyłączona. 

Domyślam się, że chodzi tobie o odgórne zablokowanie portów przez dostawcę.

   Sprawdziłem stroną https://www.whatsmyip.org/port-scanner/

Stwierdza,że zamknięte, nie jestem pewny czy taka forma starczy, gdzieś przeczytałem, że cyfrowy ... blokuje porty. Szkoda, że o tym nie pomyślałem.

   Przeczytałem też, że problemem może być prywatne IP i bycie za jakimś NAT. Nie wiem o co tu chodzi, ale podobno da się to jakoś pominąć. Czy rzeczywiście istnieje taka opcja? I jeśli istnieje to jak miałbym ją wdrożyć?

 

0.0.0.0 już testowałem rezultat identyczny

127.0.0.1 efekt ma taki, że serwer startuje ale nawet po Lan go nie widzi. zgaduje, że musiałbym łączyć się właśnie z tym adresem

 

Właśnie zauważyłem, że serwer ma to samo zewnętrzne IP co mój komputer. TO pewnie sprawia problemy.

Edytowano przez Kinggred
Uzupełnienie informacji

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Bądź aktywny! Zaloguj się lub utwórz konto

Tylko zarejestrowani użytkownicy mogą komentować zawartość tej strony

Utwórz konto

Zarejestruj nowe konto, to proste!

Zarejestruj nowe konto

Zaloguj się

Posiadasz własne konto? Użyj go!

Zaloguj się
  • Kto przegląda   0 użytkowników

    Brak zalogowanych użytkowników przeglądających tę stronę.

×
Okienko zamknie się za 5 sekund...