Skocz do zawartości

Polecane posty

Witam,
Mam problem z kitami na serwerze. Otóż kity z essentials działały do momentu instalacji pluginu CloudSkyWars.
Plugin ten niejako "przejął" komendę "/kit".
Gdy chcę użyć któregoś z kitów (essentials), w konsoli wyskakuje taki oto błąd:

"[12:19:10 ERROR]: Unhandled exception executing command 'kit' in plugin CloudSkyWars v4.8
org.bukkit.command.CommandException: Unhandled exception executing command 'kit' in plugin CloudSkyWars v4.8
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:46) ~[spigot.jar:git-Paper-1512]
        at com.earth2me.essentials.Essentials.onCommandEssentials(Essentials.java:441) ~[?:?]
        at com.earth2me.essentials.Essentials.onCommand(Essentials.java:430) ~[?:?]
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44) ~[spigot.jar:git-Paper-1512]
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:151) ~[spigot.jar:git-Paper-1512]
        at org.bukkit.craftbukkit.v1_12_R1.CraftServer.dispatchCommand(CraftServer.java:685) ~[spigot.jar:git-Paper-1512]
        at org.bukkit.craftbukkit.v1_12_R1.CraftServer.dispatchServerCommand(CraftServer.java:648) ~[spigot.jar:git-Paper-1512]
        at net.minecraft.server.v1_12_R1.DedicatedServer.aP(DedicatedServer.java:461) ~[spigot.jar:git-Paper-1512]
        at net.minecraft.server.v1_12_R1.DedicatedServer.D(DedicatedServer.java:424) ~[spigot.jar:git-Paper-1512]
        at net.minecraft.server.v1_12_R1.MinecraftServer.C(MinecraftServer.java:773) ~[spigot.jar:git-Paper-1512]
        at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:665) ~[spigot.jar:git-Paper-1512]
        at java.lang.Thread.run(Unknown Source) [?:1.8.0_211]
Caused by: java.lang.ClassCastException: com.destroystokyo.paper.console.TerminalConsoleCommandSender cannot be cast to org.bukkit.entity.Player
        at teamgx.kubig25.skywars.cmd.BaseKit.onCommand(BaseKit.java:20) ~[?:?]
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44) ~[spigot.jar:git-Paper-1512]
        ... 11 more
[12:19:10 INFO]: An internal error occurred while attempting to perform this command"
A w samej grze, gdy wpiszę np "/kit gracz", pojawia się jedynie "/kit [kit] [player]". Serwer na spigocie, 1.12.2.
Czy jest opcja, aby się tego pozbyć? Jeśli tak, to jak?
Z góry dziękuję za pomoc.
 

Edytowano przez ThePlayer69

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
30 minut temu, sk8erace1 napisał:

Jest tam komenda "kit", która kłóci się z Essentialsem.

Zauważyłem. Czy jest opcja aby to naprawić? Nie chciałbym rezygnować z pluginu na sky warsy.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Bądź aktywny! Zaloguj się lub utwórz konto

Tylko zarejestrowani użytkownicy mogą komentować zawartość tej strony

Utwórz konto

Zarejestruj nowe konto, to proste!

Zarejestruj nowe konto

Zaloguj się

Posiadasz własne konto? Użyj go!

Zaloguj się
  • Kto przegląda   0 użytkowników

    Brak zalogowanych użytkowników przeglądających tę stronę.

×
Okienko zamknie się za 5 sekund...