Skocz do zawartości

Stary HDD - uruchomienie na nowym PC

Polecane posty

Cześć

W związku z awarią mojego starego PC, wczoraj złożyłem nowy, od zera i i bez wykorzystywania starych podzespołów, wszystko już działa, łącznie z systemem (przesiadka na w10) itd ale bardzo chciałbym odzyskać część danych z poprzedniego kompa. 

Wypiąłem dysk HDD (sata 2 chyba) i podłączyłem do nowego PC, oczywiście nie jestem w stanie odczytać z niego danych bo jest na nim postawiony system (jedyny dysk w poprzednim komputerze). Po zmianie bootowania na ten dysk, windows wstaje, uruchamiają się aplikacje z autostartem itp ale nie jestem w stanie nic zrobić bo nie działa klawiatura ani myszka. Domyślam się, że to dlatego, że sterowniki się nie zgadzają, poprzedni komputer był na intelu i miał 4-5lat a nowy jest na AMD. Instalacja sterowników w Windowsie nie jest możliwa bo nie mam jak rozpocząć instalacji bez klawiatury albo myszki. W UEFI wszystko działa jak trzeba.

Pytanie moje to czy jest jakiś sposób na odzyskanie danych z tego dysku nie mając do dyspozycji innego komputera? Próbowałem użyć przejściówki SATA-USB ale 3,5' nie chce ruszyć (nawet go w bootowaniu nie wykrywa) czego się spodziewałem...

 

Płyta główna w nowym PC to AsRock B450 Gaming 4k 

Peryferia podłączam przez USB (do płyty głównej i do portów w obudowie próbowałem)

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Pani Kasia

To nie uruchamiaj systemu i skopiuj dane podpinając ten dysk. 

 

Niezrozumiałe jest jak nie możesz odczytać danych z podpiętego dysku, szyfrowałeś go czy co ?

Nie problem podpiąć inną klawiaturę czy myszkę , zwykle przesiadka z Intela na AMD pozwala bez problemu wystartować system. 

Edytowano przez Ktosiu

Mózg to nie mydło; nie ubędzie Ci go, gdy go użyjesz.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Autor tematu Napisano (edytowany)

Mam teraz dwa dyski. Nowy SSD z Win10 i stary HDD na którym jest win7, nowy normalnie śmiga, używam obecnie ale na starym dysku jak jest wpięty to włączając kompa na nowym, w "Ten Komputer" nie mam drugiego dysku, nie widzi go. Uruchamiając kompa na tym drugim dysku, normalnie windows 7 się uruchamia ale nic nie działa oprócz systemu, obraz w rozdzielczości chyba 800x600, aplikacje z autostartem uruchamiają się żałośnie długo. Nic co podpinam nie działa, nie ważne czy to myszka, klawiatura, pendrive czy stacja dysków na usb czy nawet monitor kablem VGA, musiałem podpinać kablem DVI-D HDMI żeby się wpiąć bezpośrednio z karty graficznej bo inaczej obrazu nie ma (VGA w płycie głównej jest, HDMI z w karcie graficznej)

 

Dysk nie był szyfrowany, po prostu płyta główna w starym padła więc wyciągnąłem z niego dysk i wpiąłem do nowego.

 

Próbowałem zamieniać miejscami dyski i wpinać pojedynczo, nic to nie zmieniło

Edytowano przez xcepax

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Pani Kasia

Nie wiem co sobie myślałeś ale nie przestawiłeś wcześniej biosu pod dyski. 
 W7 i w10 działają całkowicie na odmiennych systemach partycji MBR i GPT a na dodatek całkowicie odmiennych systemach obsługi BIOS-u Legacy i UEFI. Nie skonfigurowałeś po prostu  BIOS.  

 

Wystarczy ustawić pod nowy system wszystko na UEFI , z secure boot itp. Drugi dysk wystarczy tylko wpiąć pod SATA/ATA co tam masz. 


Mózg to nie mydło; nie ubędzie Ci go, gdy go użyjesz.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Windows 10 na nowym dysku działa, chodzi o stary dysk z starym systemem.

 

Jeśli dobrze zrozumiałem, wystarczy, że z podłączonym dyskiem wejde w BIOS i coś zmienie a następnie odpale bootowanie systemu z starego dysku z win7 i będzie działać wystarczająco do zgrania potrzebnych danych? Co mam tam ustawić? Coś widziałem w zakładkach z wyborem Legacy i UEFI ale aż takiej zaawansowanej wiedzy o tym nie posiadam.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Wystarczy podłączyć stary  dysk i z nowego system skopiować. 


Mózg to nie mydło; nie ubędzie Ci go, gdy go użyjesz.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Pani Kasia

Windows 10 nie widzi tego dysku mimo, że bez problemu da się go uruchomić z boot menu :/

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

A próbowałeś wpinać dysk pod inny SATA?  Nie powinno być problemu z odczytem dysku chyba że jest zaszyfrowany. 

Sprawdź w zarządzaniu dyskami czy dysk jest widoczny i zamontowany.   Najlepiej to by było podpiąć go przez kieszeń  na USB . 

 

Jeszcze jeszcze możliwości kilka ale najważniejsze to : 

- czy  nie miałeś czasami tego dysku jako dynamicznego i nie łączyłeś tak na nim partycji

- czy czasami nie jest załączona hibernacja na starym systemie , problem jest wtedy z powodu blokady odczytu dysku przez inny system niż macierzysty. 

- wyłącz w biosie  Quick Boot nich system sam odczyta informację o urządzeniach. 

- uruchom system z tego dysku ustawiając LEGACY zamiast UEFI

 

  Jeśli coś zadziała albo spełniasz któryś z warunków  pozostaje tylko start z tego dysku w trybie awaryjnym i w tym trybie skopiowanie danych z dysku na inny dysk czy pena.  Po skopiowaniu dysk nadaje sie tylko do usunięcia partycji i założenia nowych . 


Mózg to nie mydło; nie ubędzie Ci go, gdy go użyjesz.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Bądź aktywny! Zaloguj się lub utwórz konto

Tylko zarejestrowani użytkownicy mogą komentować zawartość tej strony

Utwórz konto

Zarejestruj nowe konto, to proste!

Zarejestruj nowe konto

Zaloguj się

Posiadasz własne konto? Użyj go!

Zaloguj się

  • Kto przegląda   0 użytkowników

    Brak zalogowanych użytkowników przeglądających tę stronę.

×
Okienko zamknie się za 5 sekund...