Skocz do zawartości

Polecane posty

Autor tematu Napisano (edytowany)

Witam, mam taki problem, że na jednym serwerze innego hostingu mam obciążanie 1500mb ram, a TitanAxe ponad 3.5 i cały czas rosnie po trochu, aż wywali serwer, nie ma róż ich ile dodam ram. Przeczytalem opinie, że ten serwer jest pod pieniądze, zaczyna mnie irytować ta sytuacja, napewno zmienię hosting.

Sprawdzałem pluginy, wszystko po kolei, wgrałem nowy silnik i to samo. 

Jakie Wy macie opinie? 

Edytowano przez reju10

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Pani Kasia

Pisałem, dostałem tylko opdowiedz, że to nie ich wina. 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Pani Kasia

Niestety też tak często mam ale czasem poprostu się uspokaja mam dość sporo pluginów ale to nie jest ich wina bo sprawdzałem krok po kroku jedyne co ci moge doradzić to restarty ( automatyczne nie plugin ) prawie na samym dole masz 'harmonogram zadań ' zrób tam co jakiś czas restarty


Posty: 10, 25, 50,100125, 150, 175, 200225250, 275, 300, 325, 350, 375, 400, 425, 450, 475, 500

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

To jest ich wina. Już wielokrotnie spotkałem się z opinią, że Titanaxe zawyża zużycie RAM'u. Najlepiej zmień hosting na Craftserve (mniej profesjonalny) lub Lvlup (bardziej profesjonalny).

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

ram jest przekłamany, serverpro na 1gb ram ma taką samą wydajność jak titanaxe 3500 ramu

Edytowano przez ninja12412

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Pani Kasia

Nie jest to prawda, to stwierdzenie jest krzywdzące. Hosting nie przekłamuje RAM, niczego nie dokłada - w panelu pokazane jest rzeczywiste użycie RAM przez serwer VPS na którym uruchomiona jest instancja serwera MC. Do każdego serwera dodajemy ok. 500-800MB RAM na rezerwę. Prawdopodobną przyczyną problemów z RAM jest wyciek pamięci w jednym z pluginów lub nawet silniku. Można to sprawdzić, uruchamiając serwer bez pluginów. Zapraszam do kontaktu z supportem, sprawdzimy ten przypadek dokładniej.

 

Hosting zapewnia miejsce do uruchomienia aplikacji użytkownika i to w jaki sposób ona działa, zależy głównie od samego użytkownika. Serwer powinien używać stale minimum 80% swojej pamięci - jeżeli nie wykorzystuje, to wyrzucasz pieniądze w błoto (no chyba, że potrzebujesz dużo CPU, to jest to uzasadnienie). Jeżeli serwer się restartuje, sprawdź pluginy, ogranicz świat, dodaj RAM, bo może mu jednak brakować. Jeżeli jest tzw. "wyciek pamięci" (ciągła alokacja, np. spawnowanie zwierząt non stop), to jest to normalne, że serwer w końcu sięgnie limitu. Logiczne. A jeżeli serwer się nie restartuje, a użycie jest bliskie 100%, nie jest to problem - Java tak działa. Zwalnianie pamięci kosztuje czas procesora. 

 

Jedynym ograniczeniem na hostingu i tym, co powoduje najczęstsze problemy, to ograniczenie CPU. Hosting gwarantuje przydział CPU proporcjonalnie do użycia RAM - w cenniku jest to wyszczególnione i logiczne jest to, że serwer nie jest z gumy i gdzieś ma limity. Dlatego w TITANAXE nie ma serwerów "bez limitu", bo to jest kłamstwo. Zwykle osoby skarżące się na małą wydajność / lagi, przekraczają limit CPU 2-3 krotnie - i to nie jest ani karane, serwera nie wyłączamy, itp. Jeżeli są wolne zasoby, pozwalamy używać nawet 100% CPU. Wersje MC od 1.13+ wymagają bardzo dużo zasobów. Takim klientom, którzy potrzebują więcej zasobów oferowane jest przeniesienie na inny serwer dedykowany, gdzie jest więcej "luźnego" CPU. Jeżeli ktoś ma problem z wydajnością, zalecamy kontakt z supportem. Musicie wiedzieć, że w tym okresie, na wszystkich hostingach tego typu przybyło 2-3x więcej serwerów MC i zwyczajnie serwery dedykowane nie mają wolnych zasobów, dlatego ciągle dostawiane są nowe maszyny, żeby obsłużyć dodatkowy ruch. 

 

Zależy nam na Waszym zadowoleniu, dlatego każdy przypadek sprawdzamy indywidualnie. 95% przypadków to są te same problemy - podstawowe błędy konfiguracyjne. Żeby rozwiązać problem, trzeba współpracować. Jeżeli support napisał, że jest to problem z konfiguracją, to znaczy, że tak jest. 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
13 minut temu, reju10 napisał:

xD = i mamy dodawać ram bez końca. Pzdr

 

Nie, tak robią kompletni amatorzy, którzy nie mają pojęcia co robią. Te same problemy będą wszędzie, nawet tam, gdzie "nie ma limitu" - kiedyś do niego dotrzesz. 

 

Przykład z dzisiaj, problem z zapychaniem RAMu, rozwiązanie problemu: "zainstalowany był plugin world border, który jak się okazało uruchomione miał ładowanie chunków i tak działał sobie w tle, ale ze względu na to, że kilka razy serwer sam się zresetował, plugin jakby się zbugował i nie pokazywało nigdzie informacji o renderowaniu chunków".

 

Pozdrawiam uprzejmego klienta. Zasługuje na solidny rabacik za dzielenie się wiedzą. 🙂 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Autor tematu Napisano (edytowany)

Napisałem do supportu, skonfigurowałem, zainstalowałem pluginy od nowa, zmieniłem silnik, dalej było to samo u mnie, jedynie dostałem odpowiedź, że sam mam sobie to naprawić. Przeczytałem dużą ilość opinii, w których ludzie pisali to samo, więc to raczej nie moja wina.

https://imgur.com/8NJxmzZ

Edytowano przez reju10

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Pani Kasia

2 minuty temu, reju10 napisał:

Napisałem do supportu, skonfigurowałem, zainstalowałem pluginy od nowa, zmieniłem silnik, dalej było to samo u mnie, jedynie dostałem odpowiedź, że sam mam sobie to naprawić. Przeczytałem dużą ilość opinii, w których ludzie pisali to samo, więc to raczej nie moja wina.

Instalowanie tych samych pluginów, jeszcze raz, bez zastanowienia się co jest nie tak, niczego nie zmienia. Cytując Alberta Einsteina: "Szaleństwem jest robić wciąż to samo i oczekiwać różnych rezultatów”. 😁

 

Jako ciekawostka, z życia hostingu. Użytkownicy skarżą się często, że serwer MC nie działa. Zalecamy wykonanie reinstalacji serwera (przywrócenie oryginalnych pluginów). Użytkownik to robi, po czym od razu wgrywa swoje pluginy i pisze: "dalej to samo, nie działa". 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Czyt. pobranie najnowszych pluginów i wgranie ich od nowa, usunięciem folderów pluginów. Na dodatek te same pliki stoją na serwerze, który ma 1000 czy tam 1500mb ram na innym hostingu i jest stałe 1300-1800mb, więc może Pan marcinc81 zakończyć robienie ze mnie debila. Pozdrawiam 🙂

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
14 minut temu, reju10 napisał:

Czyt. pobranie najnowszych pluginów i wgranie ich od nowa, usunięciem folderów pluginów. Na dodatek te same pliki stoją na serwerze, który ma 1000 czy tam 1500mb ram na innym hostingu i jest stałe 1300-1800mb, więc może Pan marcinc81 zakończyć robienie ze mnie debila. Pozdrawiam 🙂

Proszę przesłać te pliki serwera do nas na [email protected], odpalimy, sprawdzimy. To będzie jedyne wyjście z twarzą obecnej sytuacji dla każdej ze stron. 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Cytat

Support niestety nie pomaga w konfiguracji. Support rozwiązuje problemy techniczne związane z dostępem do serwera a nie z jego konfiguracją - w punkcie 9.6 regulaminu jest to zawarte. Należy szukać porad na wiki.titanaxe.com lub w Internecie.

Jedynym plusem jest to, że można kupić dostęp na 7dni, dzięki temu można szybko zrezygnować i szybkie odpowiedzi od supportu. Przeszedłem już na inny hosting, odemnie to wszystko.

Pozdrawiam.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
2 minuty temu, reju10 napisał:

Jedynym plusem jest to, że można kupić dostęp na 7dni, dzięki temu można szybko zrezygnować i szybkie odpowiedzi od supportu. Przeszedłem już na inny hosting, odemnie to wszystko.

Pozdrawiam.

Zazwyczaj tak jest, jak przychodzi do merytorycznej dyskusji, ona szybko się kończy, bo argumentów brak. Pozdrawiam również. 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

" xD " = nie brak, tylko już wystarczająco dużo argumentów dałem, z plikami jest wszystko ok, na pierwszym hostingu z ramem 1024mb działa, a po waszym hostingu sprawdziłem następny i działa bez zarzutów, ciekawe czemu akurat u was nie działa. To nie jest tylko moja opinia, proszę spojrzeć na opinie wyżej i wpisać w google " opinie titanaxe " = wyświetlą się bardzo podobne opinie. 🙂

Pozdrawiam, miłego dnia.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
1 minutę temu, reju10 napisał:

" xD " = nie brak, tylko już wystarczająco dużo argumentów dałem, z plikami jest wszystko ok, na pierwszym hostingu z ramem 1024mb działa, a po waszym hostingu sprawdziłem następny i działa bez zarzutów, ciekawe czemu akurat u was nie działa. To nie jest tylko moja opinia, proszę spojrzeć na opinie wyżej i wpisać w google " opinie titanaxe " = wyświetlą się bardzo podobne opinie. 🙂

Pozdrawiam, miłego dnia.

właśnie tego chcę się dowiedzieć, co jest przyczyną. Bo jeżeli to się powtarza i nie jest związane z konfiguracją serwera, konieczna jest natychmiastowa interwencja. Bez współpracy, nie ma rozwoju. 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Problem rozwiązany. Nie udało się potwierdzić wersji @reju10. Serwer normalnie uruchomił się na 1500MB, użycie 1100MB, zgodnie z tym, co pisałem. Nic nie zostało zmienione na hostingu ani w serwerze. Zasadniczo @reju10 powinien to napisać, ale jak to powiedział: „zdania nie zmienię” - chociaż fakty są inne. Tak czy siak, ja się nie gniewam, ważne że związek takich problemów z hostingiem został wykluczony porzez prosty test. 
 

Na podobne problemy z wyciekami pamięci polecamy LaggRemover (lub podobne) - sprawdzone u innego klienta z podobnymi objawami. Teraz klient ma użycie RAM na poziomie 3 z 5.5GB i jest stałe. Pamiętajcie, do ok. 80% przydziału RAM Java alokuje i jest to normalne. Nie normane jest przekraczanie limitu i restarty serwera. 
 

Powtórzę, hosting nie stosuje dziwnych praktyk „zawyżania RAM”, jest to karalne w relacjach firma - konsument, więc z czystego bezpieczeństwa finansowego takie prakyki są wręcz idiotyczne i zagrożone surowymi mandatami od UOKiK. Tego typu opinie są nieprawdziwe i krzywdzące. Nie wyciągam konsekwencji prawnych za to, ale sugerowanie, że takie praktyki stosujemy, jest działaniem na moją szkodę i zgodnie z obowiązującym prawem, mogę się domagać jej naprawy. Podchodźmy do tego racjonalnie i obiektywnie. To, że kilka osób napisało podobną bzdurę, nie oznacza, że to jest prawda. Kilkadziesiąt tysięcy użytkowników TITANAXE tego nie potwierdza. Pozdrawiam! 
 


 

 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Właśnie potwierdziłeś to, co napisałem. Przeczytaj, najpierw. Rzeczywiście, nie komentuj już. 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

@reju10 Jeżeli mogę wiedzieć, na jaki hosting się przeniosłeś? Mam ten sam problem z titanaxe, czyszczenie serwera itp ponowna reinstalacja, wgrywanie najnowszych wersji i problem ten sam jest, ram dochodzi do 5,5GB i serwer się restartuje gdzie gra 8 osób. To jest dziwne, w odpowiedzi od Titanaxe uzyskałem że "Witam, lepiej zrobić kopie zapasową przed zmianami. Co do ramu to tyle serwer potrzebuje. Najlepiej sprawdzić pluginy dokładnie które najwięcej biorą ram." Tyle serwer potrzebuje? ram został podniesiony z 3GB do 5GB i dalej to samo?..

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

@Mauri_Mine zaktualizuj silnik - w ostatniej wersji poprawili duży problem z wyciekiem pamięci. Można też laggremover zainstalować. Pomogło wielu klientom. 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Bądź aktywny! Zaloguj się lub utwórz konto

Tylko zarejestrowani użytkownicy mogą komentować zawartość tej strony

Utwórz konto

Zarejestruj nowe konto, to proste!

Zarejestruj nowe konto

Zaloguj się

Posiadasz własne konto? Użyj go!

Zaloguj się

  • Kto przegląda   0 użytkowników

    Brak zalogowanych użytkowników przeglądających tę stronę.

×
Okienko zamknie się za 5 sekund...